Příklad: Vyhledání stejných hodnot ve dvou seznamech

Tento příklad s cílem potvrzení shodnosti seznamů nebo nalezení rozdílu ukazuje jednu z nejčastějších oblastí využití naší funkce SVYHLEDAT.

Mnozí pokročilí uživatelé Excelu využívají funkci SVYHLEDAT pro dohledání rozdílných položek v různých seznamech. Vraťme se k našemu prvnímu příkladu se směrovacími čísly a předpokládejme, že máme k dispozici dvojici seznamů (původní a aktualizovaný) a chceme zjistit, zda jsou tyto seznamy identické (list SVYHLEDAT-C ukázkového příkladu):

Srovnání dvou seznamů.

Chceme zjistit, zda jsou dva seznamy identické.

Do první buňky sloupce, kde chceme vidět výsledek (G2) zapíšeme vzorec =SVYHLEDAT(A2;D:E;1;0) a následně jej zkopírujeme do všech zbývajících buněk.

Funkce SVYHLEDAT nalezla jeden rozdíl mezi oběma seznamy – v původním seznamu (sloupec A) je obsažena obec Chocerady, která však chybí v aktuálním seznamu. Protože oba seznamy mají stejný počet hodnot, je logicky chybějící hodnota nahrazena jinou. Která to je, však zatím z výsledku hledání nezjistíme. K tomu nám pomůže druhý příklad s opačným vyhledáváním (nalezení aktuální hodnoty v původní), který je na listu SVYHLEDAT-D:

Nalezení rozdílu mezi seznamy.

Nalezení rozdílu mezi seznamy.

Vidíme, že aktuální seznam obsahuje obec Chočerady, která však není v původním seznamu obsažena. Výsledkem oboustranného vyhledávání je tedy následující informace:

  • seznamy se liší v jedné položce,
  • tato položka má v původním seznamu hodnotu „Chocerady“, kdežto v aktuálním seznamu má hodnotu „Chočerady“.

Další příklady z praxe:

Autor textu: Ing. Marek Laurenčík, společnost JUBELA, s.r.o.